Setting mobile scroller hScroll fails

Monte Goulding monte at appisle.net
Tue May 28 19:33:13 EDT 2019


Hi Jacque

I’m thinking you are over summarising what you are doing here. For example, I expect you mean to set the hScroll of the group to the formattedWidth - the width of the group. Are you setting the contentRect appropriately before setting the hScroll of the scroller?

Cheers

Monte

> On 27 May 2019, at 8:03 am, J. Landman Gay via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> I want to verify this is a bug and not just me.
> 
> I'm creating a mobile scroller over a group. I want the group to initially display with its hScroll all the way to the right. I'm doing this:
> 
> zoom the group out to fill the screen
> create a mobile scroller with the same rect
> set the hScroll of the group to its formattedWidth
> set the hScroll of the scroller to the scroll of the group
> 
> If I insert an answer command to show the scroller's hScroll it reports the correct number. But the scroller always acts like its scroll is 0, and it won't scroll to the left at all. But scrolling it to the right zaps both it and the group to zero and after that it scrolls normally.
> 
> I've also tried not setting the group's scroll and just setting the scroller alone, thinking it might trigger the scrollerDidScroll handler, but it doesn't.
> 
> If I don't set any hScroll at all on either the group or the scroller, all is well.
> 
> Has anyone else seen this?
> 
> -- 
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list