Android needs 64 bit builds

Brian Milby brian at milby7.com
Mon May 13 20:25:44 EDT 2019


Yes, building against develop.
Using gcc 7.4.0

This was a laptop I setup about 8 months ago with Ubuntu 18.04.  I loaded all of the build stuff then but ran into the PIC issue and stopped.  I had VMs with 16.04 that I could still use to build on Linux.

After all of the recent activity I decided to give a build a try and it made it through the link process this time.

I just pulled everything again and now it fails.  My guess is that I got a “good” copy of prebuilts on my previous build somehow.  I did notice that it downloaded several prebuilts this time.

Thanks,
Brian
On May 13, 2019, 6:13 PM -0400, Mark Wieder via use-livecode <use-livecode at lists.runrev.com>, wrote:
> On 5/13/19 12:46 PM, Brian Milby via use-livecode wrote:
> > I was just able to build for the first time in Ubuntu 18.04 and it comes up 9.5 (dp 1).
> > I never went far enough to figure out how to overcome the PIC issue myself and waited for it to make it to develop.
>
> It's still in progress.
>
> Are you building against the develop branch?
> What version of gcc are you using?
> https://github.com/livecode/livecode/pull/6953/ broke the current build
> process. I have to patch a couple of build files to get it to compile.
> https://github.com/livecode/livecode/pull/6897
>
> Ian has a new PR on the way.
> https://github.com/livecode/livecode/pull/7032
>
> --
> Mark Wieder
> ahsoftware at gmail.com
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the Use-livecode mailing list