Groups do not receive mouseEnter messages?

Paul Dupuis paul at researchware.com
Mon Jun 24 19:25:11 EDT 2019


In LC9.0.5rc1 under Windows, I have a test stack with 2 opaque groups 
with show borders  - one covering the top half of the card and one 
covering the bottom half of the card. In side the top group are a couple 
buttons with plenty of white space around them and inside the bottom 
group are a couple of graphic objects with plenty of white space around 
them.

The buttons and graphics have no scripts (currently). Each group has an 
"on mouseEnter" handler that "choose browse tool" for the top group and 
"choose pointer tool" for the bottom group.  The simple idea being when 
the user moves the mouse into the bottom group, the pointer tool is 
chosen so they could click on and resize the graphics. And when the 
mouse enter the top group, the browse tool is chosen so the user can 
click on the buttons without selecting them.

Neither group seems to receive the mouseEnter messages. Instead, the 
groups mouseEnter handler is executed for the top group only when the 
mouse is moved over one of the buttons (which has no mouseEnter handler 
and so the message is passed to the group) and likewise, the bottom 
groups mouseEnter handler is executed only when the mouse is moved over 
one of the graphics.

Do GROUPs not receive mouseEnter directly? This seems like a bug?Or is 
there some trick (property settings) for a group to receive mouseEnter 
messages?




More information about the Use-livecode mailing list