Launching a cli server as background process in OSX

mines-imap francois.chaplais at mines-paristech.fr
Wed Jul 31 16:15:07 EDT 2019


If i remember correctly, shell() launches a new shell environment. It is possible that your executable is not in the current PATH. I have had this problem to execute pdftex from livecode.
Best regards
François

> Le 31 juil. 2019 à 17:24, David Bovill via use-livecode <use-livecode at lists.runrev.com> a écrit :
> 
> I have a server that I would like launch from Livecode. I've tried shell(),
> launch, open process, and then creatign bash scripts ending with "&" or
> using screen... no joy so far...
> 
> In the terminal I run:
> 
> hugo server
> 
> and a little go server runs and does it's magic. But try as I can nothing I
> do let's me launch the server from Livecode - without the script waiting
> for the never ending process to end and interface freezing.
> 
> Was about to launch into the world of tmux, or trying Applescript :( Any
> ideas?
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list