building to iOS 5.1

panagiotis merakos merakosp at gmail.com
Wed Jul 3 06:38:07 EDT 2019


Hello Ben,

You can definitely build an app for the iPad 1 in LC 7.1.4, and probably (Ι
don't remember now) in some early versions of LC 8.x.

Just make sure you choose "5.1.1 or later" in the iOS standalone settings,
and check the checkbox "build 32bit slice only"

The version of Xcode you'll need with LC 7.1.4 depends on the version of
your MacOS:

LiveCode 7.1.4 Xcode 7.2 Mac OS 10.10
LiveCode 7.1.4 Xcode 7.3 Mac OS 10.11

If you are on a newer MacOS, I am not sure if you will be able to install
Xcode 7.2 or 7.3.

Hope this helps,
Panos
--



On Wed, 3 Jul 2019 at 13:24, Ben Rubinstein via use-livecode <
use-livecode at lists.runrev.com> wrote:

> I have an iPad 1 which I could save from the e-wasteheap if I could build
> a
> simple app for it.
>
> My current install of LiveCode will only build back to iOS 8 (enough to do
> something useful for my iPad 2!).
>
> The splendid
>
> https://livecode.com/docs/9-0-4/faq/faq/#what-version-of-livecode-works-with-which-version-of-xcode-ios
>
> only goes back to iOS 6.0; but of course at one time it was possible to
> use
> LiveCode to build apps for iOS 5.
>
> I'm not sure what the limiting factors are: do I need earlier version of
> LiveCode, of Xcode, of MacOS, or all three?
>
> To save me endless miserable experimentation, does anyone know the answer?
> Is
> anyone else currently set up to do this?
>
> TIA,
>
> Ben
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list