Navigator 7.2rc1 is available

Geoff Canyon gcanyon at gmail.com
Sat Jan 26 00:13:38 EST 2019


The fold control bar uses this stack as its behavior: stack
"rev_g_groupFoldBar"

That script is:

on mouseUp
   put getID(barClickLine()) into CL
   if the number of lines of CL > 1 or word 1 of CL is not "group" then
exit mouseUp
   setFolded CL
   doUpdateDisplay true
end mouseUp

So it's pretty much down to three things:

1.a. Does barClickLine() return the proper line?
1.b. Does getID() return the right ID? And is it the long ID?
2. Does setFolded work?
3. Does doUpdateDisplay do something to reset the folds before displaying?
(This is what was wrong the last time).

One thing to try would be this:

dispatch "setFolded" to stack "revNavigator" with (the long id of <some
group navigator is displaying>),true

Navigator won't immediately update its display, but clicking in Navigator's
list or selecting Update List Now on the Action menu should do it, and then
that group should be displayed folded. I just did this and it worked for
me. If this works for you then we've narrowed the problem down to 1. If it
doesn't work, then 2 or 3.

gc

On Fri, Jan 25, 2019 at 3:11 PM Bob Sneidar via use-livecode <
use-livecode at lists.runrev.com> wrote:

> Nope. Running LC 9.0.2 Community, MacOS 10.14.2, Navigator 7.2 RC1. If you
> point me to where the folding code actually happens, I can turn on rev
> development and trace it.
>
> Bob S
>
>
> > On Jan 25, 2019, at 14:16 , Geoff Canyon via use-livecode <
> use-livecode at lists.runrev.com> wrote:
> >
> > I'm not seeing this? I tried both with a specific stack and (what I
> > remember from the last time) "this card of the topstack". Folding is
> > working for me, both by clicking in the margin, and by selecting a fold
> > level on the popup menu for a card or group.
> >
> > Any specific recipe?
> >
> > gc
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list