Release 9.0.3 RC-1 iOS Rejection (app uses the HealthKit or CareKit APIs but does not indicate integration with the Health app)

Ralph DiMola rdimola at evergreeninfo.net
Thu Feb 28 16:17:49 EST 2019


Thanks Panos!

 

 

Ralph DiMola

IT Director

Evergreen Information Services

rdimola at evergreeninfo.net

 

From: panagiotis merakos [mailto:merakosp at gmail.com] 
Sent: Thursday, February 28, 2019 3:26 PM
To: How to use LiveCode
Cc: Ralph DiMola
Subject: Re: Release 9.0.3 RC-1 iOS Rejection (app uses the HealthKit or CareKit APIs but does not indicate integration with the Health app)

 

Hello Ralph,

 

Yes, this is caused by the HealthKit-related plist entries. See this bug report, and the linked forum discussion for a workaround. Or you could apply locally the fix described in the PR

 

Best,

Panos

--

 

On Thu, Feb 28, 2019 at 9:05 PM Ralph DiMola via use-livecode <use-livecode at lists.runrev.com> wrote:

Does anyone know what this is all about?
Mac OSX 10.13.6
Xcode 10.1
LC 9.0.3 rc1

>From Apple reviewer:
---------------------
Guideline 2.5.1 - Performance - Software Requirements


Your app uses the HealthKit or CareKit APIs but does not indicate integration with the Health app in your app description and clearly identify the HealthKit and CareKit functionality in your app's user interface.

Next Steps
 To resolve this issue, please clearly identify the HealthKit functionality in app's user interface to avoid confusion.

Please see attached screenshots for details.
----------------------------

Ralph DiMola
IT Director
Evergreen Information Services
rdimola at evergreeninfo.net


_______________________________________________
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list