[ANN] Release 9.0.3 RC-1 - Plugins are listed in PB after loading a stack

Matthias Rebbe matthias_livecode_150811 at m-r-d.de
Tue Feb 26 05:11:51 EST 2019


Hi Panos,

see here Bug 21856 <https://quality.livecode.com/show_bug.cgi?id=21856>

Regards,

Matthias

Matthias Rebbe

free tools for Livecoders:
https://instamaker.dermattes.de <https://instamaker.dermattes.de/>
https://winsignhelper.dermattes.de <https://winsignhelper.dermattes.de/>

> Am 26.02.2019 um 10:58 schrieb panagiotis merakos via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>:
> 
> Hello Matthias,
> 
> This is probably caused by this change:
> 
> https://github.com/livecode/livecode-ide/pull/2011/files <https://github.com/livecode/livecode-ide/pull/2011/files>
> 
> When the name of a stack is referenced (in this case "tLine"), LC loads the
> stack into memory. Note that this does not mean the stack is open, so it
> does not appear in the openStacks.
> 
>>>>>>> Should i report this as a bug?
> 
> This is a change in behavior, but I am not 100% sure if this is a bug, so
> yes please, if you don't mind file a bug so as we discuss it with the team.
> 
> Kind regards,
> Panos
> --
> 
> 
> On Tue, Feb 26, 2019 at 11:35 AM Matthias Rebbe via use-livecode <
> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>> wrote:
> 
>> Hi,
>> 
>> something strange here with 9.0.3 RC-1 on Mac OS X.
>> 
>> After a fresh start of the IDE the Project Browser shows no stack.  So
>> that is okay, as the option 'Show IDE stacks in list' is disabled.
>> 
>> When creating a new stack the PB just shows that stack. So that is also
>> okay.
>> 
>> But after opening an existing stack, the PB lists not only that stack, but
>> many of my Plugins, although they are configured to be opened by the plugin
>> menu, and none of the  IDE stacks is listed, just plugins. I´v upload a
>> screenshot of the listed plugins to my Droplr account:
>> http://d.qck.biz/nzebFW <http://d.qck.biz/nzebFW> <http://d.qck.biz/nzebFW <http://d.qck.biz/nzebFW>>
>> 
>> The openstacks function just returns
>> 
>> Message Box
>> revNewScriptEditor 1
>> Untitled 1                       - my newly created stack
>> revTools
>> revDictionary
>> revMenuBar
>> revIDEProjectBrowser
>> mrPreis                        - my loaded stack
>> com.livecode.palette.autocomplete.completions
>> 
>> but none of the listed plugin
>> 
>> This happens as soon as i load an existing stack.
>> 
>> Was there a change in the plugin handling in LC 9.0.3?
>> 
>> Should i report this as a bug?




More information about the Use-livecode mailing list