[ANN] Release 9.0.3 RC-1

J. Landman Gay jacque at hyperactivesw.com
Mon Feb 25 21:17:56 EST 2019


Just an update. I relaunched and have been working fine in 9.0.3 for 
several hours now. I'm at a loss to explain it.

On 2/25/19 1:43 PM, J. Landman Gay via use-livecode wrote:
> On 2/21/19 8:00 AM, panagiotis merakos via use-livecode wrote:
>> We are pleased to announce the release of LiveCode 9.0.3 RC-1.
> 
> I was hoping the strange problems would diminish with this release but I 
> lasted about 5 minutes before I had to quit and return to an earlier 
> version. I'm not sure how anyone can trace this, but thought I'd just 
> post what the circumstances were. Maybe someone will find a commonality 
> in their experience.
> 
> I'm working on a splash app that opens a separate mainstack, call it 
> StackA. The script of the app stack is inserted into the back. I was 
> debugging a handler on a card in StackA. The script editor was open and 
> a red-dot breakpoint was set.
> 
> I called the handler from the message box. -> Can't find handler
> The message box indicated that StackA was the target stack, and typing 
> "the defaultstack" in the message box also returned "StackA"
> 
> Repeated the message box call. -> Can't find handler.
> 
> Used the keyboard shortcut to summon the contextual menu and send the 
> handler name's message to the card. -> Works. Handler runs. Stops at 
> breakpoint.
> 
> I immediately saw a problem and aborted the handler in the middle. Made 
> some corrections and applied the script.
> 
> Called the handler from the message box. -> Can't find handler.
> Tried the contextual menu -> No response, no menu
> Tried "edit script of this cd" -> No response
> Tried "edit script of this cd of stack "StackA" -> no response
> Use keyboard shortcut to switch to Edit tool -> no response
> Tried clicking the Edit tool on the palette -> hilites, returns to 
> browse tool
> Repeated Edit tool selection from tools palette -> hilites, returns to 
> browse tool, but now I see it actually did choose the edit tool. I see 
> arrow-with-cross cursor.
> Double-click a field just to test -> no response
> Type in msg box: there is a fld "blah" -> true
> Use Application Browser to get the field property inspector -> works
> Click the Script button in property inspector -> no response
> 
> At this point I know I'm a hair's breadth away from a crash, so I quit 
> and return to LC 9.0.2 where this happens frequently but not quite as soon.
> 
> Anyone have anything in common with this sequence? I don't know what 
> triggers it, but the symptoms are usually the same: loss of keyboard 
> control, inability to find the current stack or card (although the 
> message box knows what it is,) inability to select or edit objects 
> except via Application Browser, and eventually a crash if you persist 
> long enough.
> 


-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com




More information about the Use-livecode mailing list