Colorizing line only works once?

Tom Glod tom at makeshyft.com
Mon Feb 25 11:03:52 EST 2019


i have no idea why this is happening, but I do a lot of work with data
grids....and the rows in a grid are self referenced, so its unlikely to be
a bug in the grid.


   - dgline and dgindex are different, and as bob said, when the sort is
   on, you have to work with dglines.
   - rows are cached and must be refreshed (make sure you set the controls
   of each row and not assume that the default row state is what will show up)
   - remember to use the "of me" syntax with every change you make to the
   controls of each row


It is likely to turn out a bug in your code ...... so thats the good part.

Good luck, let us know

On Mon, Feb 25, 2019 at 10:43 AM Bob Sneidar via use-livecode <
use-livecode at lists.runrev.com> wrote:

> If the datagrid is sorted differently than the order the data is in, you
> may get that. I ran into this in the past I think.
>
> Bob S
>
>
> > On Feb 24, 2019, at 03:46 , JJS via use-livecode <
> use-livecode at lists.runrev.com> wrote:
> >
> > Just did some tests. with the test stack from the lesson and with my own
> stack
> >
> > It seems there is something strange with my indexes.
> >
> > I would think that if a DG is emptied and then filled again that the
> index would start at 0 or 1 again.
> >
> > It seems not the case and i see random numbers
> >
> > so i have to figure out why this is happening
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list