Weird LiveCode Plugins Prefs writing problems

Richard Gaskin ambassador at fourthworld.com
Fri Feb 8 21:45:22 EST 2019


William Prothero wrote:


 > Folks:
 > Livecode 9.0.2 business Mac OSX 10.14.2
 >
 > I can’t figure this out. I’m having problems with LiveCode Plugins
 > writing prefs to the Plugins folder on my Mac. None of the prefs
 > for the extensions are able to update. At first, I thought it was
 > a problem with 4WDevolution, but now it’s with Navigator and won’t
 > install Hermann’s Turnimage extension. The prefs files (not TurnImage,
 > which throws an error) show up in the extensions folder with a “~”
 > after them, indicating it’s a temporary file with 0 bytes and that
 > the save has failed. So I can see that there is an attempt to write
 > the prefs file in the correct place, but replacing the older file
 > with the new file fails.r
 >
 > I’ve got bitDefender and “CleanMyMac”. However, I can write, and
 > update test data, with a livecode script, to the Plugins folder so
 > I am really stuck and out of ideas.
 >
 > This is very puzzling. Has anybody else seen this behavior?

I haven't, but I'm sure we can solve it.

What is the full path to your Plugins folder?

-- 
  Richard Gaskin
  Fourth World Systems
  Software Design and Development for the Desktop, Mobile, and the Web
  ____________________________________________________________________
  Ambassador at FourthWorld.com                http://www.FourthWorld.com




More information about the Use-livecode mailing list