Mac Standalone/Pkg Weirdness

Rick Harrison harrison at all-auctions.com
Wed Nov 21 15:42:59 EST 2018


Hi Tom,

I just checked the size of the icns icon in the resources folder,
and it says it is 2.9mb in size so I’m assuming that is probably OK.

Other ideas?

Thanks,

Rick

> On Nov 21, 2018, at 2:00 PM, Tom Glod via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> I'm not sure if this applies fully to your case ......i remember building
> mac standalones and having to manually replace the standalone icns icon in
> the resources folder.  u can tell which one needs replacing because the
> byte size of the icon is 0.
> 
> but i used to set the application icon in the standalone settings.  maybe
> the problems are related.
> 
> On Wed, Nov 21, 2018 at 12:26 PM Rick Harrison via use-livecode <
> use-livecode at lists.runrev.com> wrote:
> 
>> I have a Macintosh stack that I have set the
>> Application Icon and the Small Application Icon
>> to .png icons on a card.  They work fine in the IDE.
>> (MacBook Pro, macOS High Sierra, LC 9.0.1)
>> 
>> When I create a Standalone and test it.  It works
>> fine and they show up in my ask and answer dialogs.
>> 
>> After packaging everything up in the Terminal I end up
>> with a package that installs just fine.  The standalone
>> from that package works fine on my development
>> computer - (MacBook Pro.)
>> 
>> I copied the package to a USB Thumb-drive.  I then
>> plugged it into another older iMac running El-Capitan
>> to test it. The package installs the app just fine.
>> The app runs fine except that now the ask and answer
>> dialogs do not display the icons!
>> 
>> Also of interest, I had set the Destroy-stack property
>> set to true so that when the user quits the application
>> the application doesn’t stay in memory.  (I tried this
>> stack on a new mac mini running Mojave too, (yes
>> I know that LC doesn’t officially support Mojave yet
>> but I thought I would try it anyway.))  The app ran
>> fine except for the icon problem again, and this time
>> when I quit the application, the icon down in the dock
>> that shows running applications never went away
>> even after the app quit.  It looks like Destroy-stack
>> isn’t working.
>> 
>> Suggestions?
>> 
>> Thanks,
>> 
>> Rick
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list