Android APK sanity check

chipsm at themartinz.com chipsm at themartinz.com
Thu May 31 17:12:04 EDT 2018


Hi Jacque,
I just tried your test stack and I can't get it to complete the APK to load
on either of my devices. This is odd. I tried loading my application right
after to make sure I hadn't made any changes to the Android Stand-Alone
settings and I was able to compile my application.


-----Original Message-----
From: use-livecode <use-livecode-bounces at lists.runrev.com> On Behalf Of J.
Landman Gay via use-livecode
Sent: Thursday, May 31, 2018 1:02 PM
To: How to use LiveCode <use-livecode at lists.runrev.com>
Cc: J. Landman Gay <jacque at hyperactivesw.com>
Subject: Re: Android APK sanity check

Thanks for the comments. I've actually seen the problem with initial startup
on a few apps but in this case a relaunch still crashes. :(

Since you have a few older devices, it might help the team narrow down
what's affected if you try out my test stack. Bug report is here:
https://quality.livecode.com/show_bug.cgi?id=21325

I only have Android Marshmallow on my test phone(s) but I'm betting it will
fail with any older OS. Or it may be the version of Java I installed, which
I believe LC 9 required.

On 5/31/18 2:46 PM, Clarence Martin via use-livecode wrote:
> Hi Jacque,
> You have been one of the people on the List that has answered many of 
> my questions about building Android Applications. I do have an 
> application that uses mergJSON and the problem that I have is only 
> during the initial starting of the application after the APK is 
> loaded. I also get a blank initial screen. I found that if I close the 
> application and then restart the application - it runs. I have also 
> had problems with applications locking up on one Android Device and 
> will run on another without problems. The problems that I encountered 
> were mainly opening data files across the internet on the failing 
> device. I actually solved some of those problems by putting a delay 
> after  I call for data across the internet. Both devices are using 
> Android 5.1.1. The failing Device  is a Nexus 7 and the other device 
> that doesn't fail is a generic X10 Chinese cheaper Tablet. The only other
problem I noticed with LC 9 is a latency in starting the applications.
> 
> -----Original Message-----
> From: use-livecode <use-livecode-bounces at lists.runrev.com> On Behalf Of J.
> Landman Gay via use-livecode
> Sent: Thursday, May 31, 2018 12:10 PM
> To: How to use LiveCode <use-livecode at lists.runrev.com>
> Cc: J. Landman Gay <jacque at hyperactivesw.com>
> Subject: Re: Android APK sanity check
> 
> I created a plain do-nothing stack and it works on my Samsung. Then I 
> set the inclusions to same ones in my working project. The plain stack 
> then had the same misbehavior -- black screen and crash on launch.
> 
> One by one I turned off each inclusion, tested, and then turned it 
> back on and disabled the next one. It looks like the culprit is mergJSON.
> With that included I get the crash, without it the apk behaves.
> 
> I'll submit my test stack and a bug report.
> 
> On 5/31/18 3:12 AM, panagiotis merakos via use-livecode wrote:
>> Hi all,
>>
>> The first thing that came to my mind was the bug report that Paul 
>> referenced, but I had a look at the Samsung S5 specs and it seems it 
>> has an ARM chip, so it should not be affected by this bug.
>>
>> @Jacque does that happen with any android standalone you build with 
>> LC 9.0.0, or just this particular one?
>>
>> Best,
>> Panos
> 
> 


-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com

_______________________________________________
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list