Livecode 9 Server seems not to run when custom installed on On-Rev and HostM

Matthias Rebbe matthias_livecode_150811 at m-r-d.de
Thu May 31 07:21:42 EDT 2018


Hi Ralf,

i´ve received a similar explanation today from Support, but with some additional information

"Yes, I am aware that LiveCode 9 does not work 
because of the glibc dependency problem. However, fixing it is not proving 
straightforward. The OS requires glibc 2.12 and cannot run with 2.14, but as 
you know LiveCode requires 2.14. There are possibilities of getting them 
installed together on the same machine, but Apache is not recognising the 
additional install.

Obviously we need to get LiveCode 9 running on our servers, and I'm in process 
of getting a test server so that I can work out the changes needed without 
risking everybody's accounts.”


Regarding your question:

I´ve installed 32bit Livecode Server Business and that is working now.
http://support.dermattes.de/index.lc9b <http://support.dermattes.de/index.lc9b>

Did you try to run Livecode Server from ssh command line? That sometimes returns useful error messages.


You should send a support request to support at on-rev.com <mailto:support at on-rev.com> with your problem. It seems Robin Miller is very quick in responding.
I´ve sent my normal support request yesterday evening outside the office hours of Livecode Ltd. and received an answer today at 12:51PM which is 11:51AM in the UK.
That response time is of course acceptable for non emergency requests.


Regards,

Matthias


 




> Am 31.05.2018 um 13:02 schrieb Ralf Bitter via use-livecode <use-livecode at lists.runrev.com>:
> 
> Hi Matthias,
> 
> to get LC server 9 running on On-Rev I was told by the support team:
> 
> “We can't upgrade glibc because of operating system incompatibilities. However, 
> we have installed it along side the current 2.12 version at  /opt/glibc-2.14/bin”
> 
> This means you have to launch the server executable with the glibc location
> prepended to LD_LIBRARY_PATH.
> 
> So, I put
> 
> export LD_LIBRARY_PATH=/opt/glibc-2.14/bin:$LD_LIBRARY_PATH path/to/livecode-server
> 
> towards the end of ~/.bashrc, but this didn’t help.
> 
> 
> By the way, even my 32bit LC 9 business version installation fails on Diesel.
> Did you install the community version?
> 
> 
> Ralf
> 
> 
>> On 31. May 2018, at 00:47, Matthias Rebbe via use-livecode <use-livecode at lists.runrev.com> wrote:
>> 
>> Hi,
>> today i noticed that i don´t get Livecode Server 9 Business to work  on On-Rev and HostM accounts.
>> 
>> In Browser i get an “Internal Server Error” and when running from command line in SSH session i get:
>> ./livecode-server: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./livecode-server)
>> 
>> I´ve filed already a bug <https://quality.livecode.com/show_bug.cgi?id=21319 <https://quality.livecode.com/show_bug.cgi?id=21319>>.
>> 
>> Did anyone else run into this? Or maybe is using Livecode Server 9?
>> 
>> Regards,
>> 
>> Matthias Rebbe
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list