losing font info in fields again

Bob Sneidar bobsneidar at iotecdigital.com
Tue May 29 12:35:16 EDT 2018


I just created 2 stacks. In the first, I put a field and a button, then grouped them. I then typed 2 lines of text into the field, then changed the textFont of line 1 and 2 to different fonts. I then copied the group from one stack to the other. The formatting was retained. I did this programmatically and using the menu. 

Bob S


> On May 22, 2018, at 15:43 , Dr. Hawkins via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> I think I ask this every couple of years (and it would be more often, but I
> sometimes find the answer in my archives).
> 
> As my program copies groups from one stack to another, I am losing field
> formatting information.
> 
> This time, the offending fields have, iirc, both ArialMt and dingbat text,
> probably both in different heights.
> 
> It appears that upon copy, I have a font with serifs, and the size changes.
> 
> The sharedText of the field is set to true.
> 
> I vaguely recall that the reis a field property that isn't in the inspector
> that needs to be set, but I'm baffled at the moment :(
> 
> 
> 
> -- 
> Dr. Richard E. Hawkins, Esq.
> (702) 508-8462
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list