LiveCode Builder linter support for Atom

Brian Milby brian at milby7.com
Tue May 29 11:54:26 EDT 2018


 In addition to the language-livecode package, you need to install the
linter package and the dependencies. Linter has a few settings where the
defaults seem fine.

in the language-livecode package there are a few more settings:

LiveCode server engine path (if you put it in the path, then just the name
of the executable is needd)
Compiler path for LCB and Module path for LCB.  Both of those would use the
same info as the SublimeText entries.

The readme for the package also covers the details a bit.

Thanks,
Brian

On May 29, 2018, 4:03 AM -0500, James At The Hale via use-livecode <
use-livecode at lists.runrev.com>, wrote:

Brian wrote :
<snip>

issues using Atom though and just recently got it configured for linting
both LCS and LCB (all 3 OS versions). I will admit that my use of Atom
certainly pales to what the LC staff would be doing


<snip>

I am sorry but you can’t leave it at that.
Are there (or could you share) instructions for doing this (or have i just
not seen where they are)?

James



_______________________________________________
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the Use-livecode mailing list