LiveCode - Andoid SDK - Java compatibility chart?

panagiotis merakos merakosp at gmail.com
Fri Jun 15 09:26:47 EDT 2018


Hi Tiemo,

Currently Java 9 and 10 are not supported, because of some packages being
reshuffled/removed/renamed in these versions, so LC does not find the
expected tools in the expected location.

So this is a bug in LC, not a compatibility issue. There is a bug report
here:

https://quality.livecode.com/show_bug.cgi?id=20719

However, we should have mentioned this temporary restriction on the lessons
pages. I will make sure we add it now.

So for now we advice people to install *only* Java 8.

In my setup, I have installed:

jdk1.8.0_131.jdk
SDK Tools v24.4

The older versions of Android SDK Tools now are a bit difficult to find, as
they are well-hidden in Google's archives, but for anyone interested:

http://dl-ssl.google.com/android/repository/tools_r24.4-windows.zip
http://dl-ssl.google.com/android/repository/tools_r24.4-macosx.zip
http://dl-ssl.google.com/android/repository/tools_r24.4-linux.zip

Best,
Panos
--


On Fri, Jun 15, 2018 at 2:00 PM, Tiemo Hollmann TB via use-livecode <
use-livecode at lists.runrev.com> wrote:

> Hello, Just wasted again one day with these nasty compatibility issues. I
> have followed the LC guide
> (https://livecode.com/resources/guides/mobile/android/) to install Android
> development requirements and failed, because the current versions of
> Android
> SDK and Java (10) are not compatible (at least the the JDK path doesn't
> shows up in the LC preferences.)
>
> I didn't found any compatibility chart, though I googled quite some time. I
> have seen compatibility charts for LiveCode - MacOS - Xcode once (from
> Panos
> I think), but though I know, that this chart exists somewhere in the deep
> of
> the net, I didn't found it either.
>
> After reading some other threads about these compatibility sh., without any
> solution for my current problem, I just deinstalled the JAVA sdk and
> installed an older one (8). Now it works. The solution and action to be
> taken is pretty easy - if you know it.
>
> Perhaps a compatibility chart included in that guideline (see above) would
> help others to get nuts. Or can't I just use google and the LC guidelines?
>
> Thanks
>
> Tiemo
>
>
>
>
>
>
>
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list