New Wierd Display Bug

Tom Glod tom at makeshyft.com
Wed Feb 14 20:06:01 EST 2018


sounds like a great time bob :)

On Wed, Feb 14, 2018 at 6:39 PM, Bob Sneidar via use-livecode <
use-livecode at lists.runrev.com> wrote:

> AHH HAA HAAHHAHHAA@! I just figured out why I have this problem!! One of
> my tabs is called Header. My script assumes the datagrid is named "dg" and
> the name of the tab. So I end up hiding group "dgHeader". BAAH HAHAHA HAHA
> HAHAAHAHA@
>
> Bob S
>
>
>
> > On Feb 14, 2018, at 15:35 , Bob Sneidar <bobsneidar at iotecdigital.com>
> wrote:
> >
> > UPDATE: If I show invisible objects, the datagrid header becomes
> visible. So I set the visible of group "dgHeader" of the respective
> datagrid to true and it appears again. The question is, what is hiding
> it??? I checked my scripts and I am not even referring to the dgHeader
> group in my handlers, but I AM hiding and showing the datagrids based on a
> clicked tab.
> >
> > Bob S
> >
> >
> >> On Feb 14, 2018, at 14:13 , Bob Sneidar <bobsneidar at iotecdigital.com>
> wrote:
> >>
> >> Hi all.
> >>
> >> I have 3 datagrids on a card, one for vendors, one for purchase order
> master records, and a third for po detail records. That's not important now.
> >>
> >> What IS important is that when I attempted to do some work on the card,
> I noticed the header labels for the vendors datagrid were not displaying.
> Refreshing the datagrid does no good. Editing the columns does no good.
> Believing I have another corrupted datagrid, I saved the dgprop columns,
> column labels and widths, then deleted the Vendors datagrid, then added a
> new datagrid, then restored the rect and column properties. All is well.
> >>
> >> I closed the stack then opened it later. This time the PO Master
> datagrid had the same problem but the Vendors datagrid was fine! So I did
> the same thing with the PO Detail datagrid. Next time I opened the stack
> the vendors and po master datagrids were fine, but now the po detail
> datagrid wasn't displaying!!!!!
> >>
> >> Guess what happened when I fixed the PO detail datagrid????? Yup. The
> Vendors datagrid is hosed again! This has *got* to be a display bug!!!
> >>
> >> Bob S
> >
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list