strange behaviour of standalone builder

Klaus major-k klaus at major-k.de
Mon Feb 12 08:25:01 EST 2018


Hi friends,

see subject...

I have a folder with a command line utility, one for Mac and one for Windows.
I put this into a folder in -> "specialfolderpath("resources") & "/theCLI"
adn add it via "Copy files" to my standalone.

Folder structure
theCLI (folder)
  play ## Mac version
  play.exe
  an_important.dll

Now after I built a standalone, Windows worked fine, but nothing worked on my Mac?
Usdually it is the other way round ;-)

So I took a look at the Mac application package and found that the standalone builder 
had put the Mac version of the CLI into the ENGINE folder in a "copy?" of the original folder
but only containing the Mac version? 8-)

In the standalone:
specialfolderpath("engine")
 theCLI  (folder)
   play ## Mac Version

specialfolderpath("resources")
 theCLI  (folder)
   play.exe
   an_important.dll

This is very clever of the engine on one side, but very stupid on the other!?
What gives?

So if I now access that CLI in scripts in the standalone via specialfolderpath("engine")
everything works as advertized, but this cannot be the real McCoy, does it?

Now the thing does not work in the IDE unless I script also to differ between 
IDE and standalone, no big fun really, sigh.

Tested with LC 8.1.9 stable and LC 9dp 11.

Bug or (very undocumented) feature?
Or just a egomaniacal behaviour of the engine?

Any hints, comments and whatnot very appreciated! :-)


Best

Klaus
--
Klaus Major
http://www.major-k.de
klaus at major-k.de





More information about the Use-livecode mailing list