Can't Submit App to iTunes

panagiotis merakos merakosp at gmail.com
Wed Dec 19 11:01:20 EST 2018


Hello Dan,

Indeed, Default-568h at 2x.png is required. In fact the standalone builder
puts a default image in the app bundle named "Default-568h at 2x.png" in case
the user does not provide any.

Since you have provided all the necessary icons and splash screens, I do
not see any reason why they don't appear (all of them) in the app bundle. I
take it that all the icons and splash screens you have provided are all of
the required dimensions, as specified in the tooltips of the icon/splash
fields, is that correct?

If you think it is a bug, then I suggest you file a report at
quality.livecode.com and send us (either to panos.merakos at livecode.com or
to support at livecode.com) you full stack and the set of images and icons you
use.

BTW what is the minimum target iOS version in the iOS standalone settings?
It might be worth changing it to "8.0 or later" and see if you still get
these errors.

Kind regards,
Panos
--

On Wed, Dec 19, 2018 at 5:52 PM Dan Friedman <dan at clearvisiontech.com>
wrote:

> Panos,
>
> Any word on this issue?   Colin Holgate suggested that I add all the
> portrait splash screen images even thou my app doesn't display in
> portrait.  I did that, and I got the exact same errors from Application
> Loader.
>
> -Dan
>
>
> From: panagiotis merakos <merakosp at gmail.com>
> Date: Tuesday, December 18, 2018 at 12:54 PM
> To: How to use LiveCode <use-livecode at lists.runrev.com>
> Cc: Dan Friedman <dan at clearvisiontech.com>
> Subject: Re: Can't Submit App to iTunes
>
> Hello Dan,
>
> If you right click on the .app bundle and choose "Show Package Contents",
> are the image files there?
>
> Best Regards
> Panos
> --
>
> On Tue, Dec 18, 2018 at 10:41 PM Dan Friedman via use-livecode <mailto:
> use-livecode at lists.runrev.com> wrote:
> Greetings!
>
> I've never had this problem before… When I attempt to upload my app via
> the Application Loader, I get a number of errors:
>
> ERROR ITMS-90096: "Your binary is not optimized for iPhone 5 - New iPhone
> apps and app updates submitted must support the 4-inch display on iPhone 5
> and must include a launch image referenced in the Info.plist under
> UILaunchImages with a UILaunchImageSize value set to {320, 568}. Launch
> images must be PNG files and located at the top-level of your bundle, or
> provided within each .lproj folder if you localize your launch images.
> Learn more about iPhone 5 support and app launch images by reviewing the
> 'iOS Human Interface Guidelines' at
> https://developer.apple.com/ios/human-interface-guidelines/graphics/launch-screen
> ."
>
> ERROR ITMS-90032: "Invalid Image Path - No image found at the path
> referenced under key 'CFBundleIcons': 'AppIcon60x60'"
>
> ERROR ITMS-90022: "Missing required icon file. The bundle does not contain
> an app icon for iPhone / iPod Touch of exactly '120x120' pixels, in .png
> format for iOS versions >= 10.0."
>
> ERROR ITMS-90023: "Missing required icon file. The bundle does not contain
> an app icon for iPad of exactly '152x152' pixels, in .png format for iOS
> versions >= 10.0."
>
> All icons are included in the App Settings (and they are correct, I triple
> checked!).  Also, all Splash screens are included.  I did not include the
> Portrait splash screens as the app does not use portrait display.
>
> Any thoughts?
>
> LC Indy 9.0.2
> iOS SDK 11.2
> MacOS 10.12.6
>
> -Dan
> _______________________________________________
> use-livecode mailing list
> mailto:use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>



More information about the Use-livecode mailing list