Posting to LiveCode Server

David Bovill david.bovill at gmail.com
Thu Apr 19 01:48:13 EDT 2018


Todd, the browser auto-translates things you type / copy paste in the url
bar to something it expects you want as a url.

You have characters in the url that need to be escaped (<>)

On Wed, 18 Apr 2018 at 11:51, Todd Fabacher via use-livecode <
use-livecode at lists.runrev.com> wrote:

> Any Help will be appreciated...
>
> Normally we use Node.js, but we are trying to get LiveCode server working.
> We are doing a simple test:
>
> <?lc put "It Works" ?>
>
>
> If I put the URL in a browser I get back, "It works"
>
> https://api01.triviamatic.tv/round_create.lc
> <
> https://www.google.com/url?q=https://api01.triviamatic.tv/round_create.lc&sa=D&source=hangouts&ust=1524117219848000&usg=AFQjCNFvW3yaTcJjQ9bGpWgi3CYh1mQwGA
> >
>
>
> *put* "Accept: text/plain" & CR after tHeaders
> *put* "Content-Type: application/x-www-form-urlencoded" & CR after tHeaders
> *set* the httpHeaders to tHeaders
> *put*"fullname=chi&gender=male&color=black" into tArgList
> *post* tArgList to URL "https://api01.triviamatic.tv/round_create.lc
> <
> https://www.google.com/url?q=https://api01.triviamatic.tv/round_create.lc&sa=D&source=hangouts&ust=1524117219848000&usg=AFQjCNFvW3yaTcJjQ9bGpWgi3CYh1mQwGA
> >
> "
> *put* the result into tError
> *put* it into tFormResults
>
>
> The tError is:  tsneterr: (52) Empty reply from server
>
> and tFormResults is null
>
>
> I need some help ASAP. This is SUPER frustrating!!
>
> --Todd Fabacher
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list