Posting to LiveCode Server

Matthias Rebbe matthias_livecode_150811 at m-r-d.de
Wed Apr 18 08:05:23 EDT 2018


Todd,

is there a reason why you are not using the function libURLMultipartFormData to format the data before posting?

We are using the post method for different tasks including uploading really big files to a livecode server, but we always use libURLMultipartFormData to create the form data.

Btw.which version of LC server is running on your side?


Matthias


> Am 18.04.2018 um 12:50 schrieb Todd Fabacher via use-livecode <use-livecode at lists.runrev.com>:
> 
> Any Help will be appreciated...
> 
> Normally we use Node.js, but we are trying to get LiveCode server working.
> We are doing a simple test:
> 
> <?lc put "It Works" ?>
> 
> 
> If I put the URL in a browser I get back, "It works"
> 
> https://api01.triviamatic.tv/round_create.lc
> <https://www.google.com/url?q=https://api01.triviamatic.tv/round_create.lc&sa=D&source=hangouts&ust=1524117219848000&usg=AFQjCNFvW3yaTcJjQ9bGpWgi3CYh1mQwGA>
> 
> 
> *put* "Accept: text/plain" & CR after tHeaders
> *put* "Content-Type: application/x-www-form-urlencoded" & CR after tHeaders
> *set* the httpHeaders to tHeaders
> *put*"fullname=chi&gender=male&color=black" into tArgList
> *post* tArgList to URL "https://api01.triviamatic.tv/round_create.lc
> <https://www.google.com/url?q=https://api01.triviamatic.tv/round_create.lc&sa=D&source=hangouts&ust=1524117219848000&usg=AFQjCNFvW3yaTcJjQ9bGpWgi3CYh1mQwGA>
> "
> *put* the result into tError
> *put* it into tFormResults
> 
> 
> The tError is:  tsneterr: (52) Empty reply from server
> 
> and tFormResults is null
> 
> 
> I need some help ASAP. This is SUPER frustrating!!
> 
> --Todd Fabacher
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list