[OT, maybe] - configuring a Windows Installer for a Standalone

Graham Samuel livfoss at mac.com
Tue Apr 10 13:14:39 EDT 2018


Hi Bob

Yes, your interpretation is right. InnoSetup didn’t mind the line PrivilegesRequired line (no error flagged up) but the behaviour of the final step of the installation - launch the app - gave the same error as before. But modifying the Standalone Settings as you suggested did the trick. I agree with your opinion of the UAC default. What I don’t understand is why there haven’t been more complaints about this. Heaven knows, it’s a pretty obscure and irritating process (creating installers for OS’s that one doesn’t know intimately) but you’d think others would have had the same problems as I did.

Graham

> On 10 Apr 2018, at 17:18, Bob Sneidar via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> I think he is saying that PrivilegesRequired=admin DOESN'T work, as I suspected. There is no point to running a Windows app as an administrator unless it is capable of modifying system files or altering settings only an admin can modify. By settings the UAC level to Same as Invoker (which IMHO ought to be the default) it worked for him. At least that is what I got from his email. 
> 
> Bob S
> 
> 
>> On Apr 10, 2018, at 09:10 , Matthias Rebbe via use-livecode <use-livecode at lists.runrev.com> wrote:
>> 
>> So if it´s working now with that setting and did not work w/o it then that might be a bug in Innnosetup.
>> According to the docs of Innosetup this is the default setting and therefore  does not need to be specified. 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list