[ANN] Release 9.0.0

panagiotis merakos merakosp at gmail.com
Wed Apr 4 16:09:41 EDT 2018


@Paul

ok this might be useful (the fact that clicking "yes" in the associations
dialog causes the splash to hide as expected in subsequent launches)

You are getting the gray backdrop as this is the default after clearing the
Prefs. You can change that by unchecking "View"-> "Backdrop" in the LC
menubar

Best,
Panos
--



On Wed, Apr 4, 2018 at 8:54 PM, Paul Dupuis via use-livecode <
use-livecode at lists.runrev.com> wrote:

> On 4/4/2018 1:51 PM, panagiotis merakos via use-livecode wrote:
> > @Peter
> > One more thing to try before filing a bug report:
> >
> > 1. Clear Prefs again
> > 2. Open LC, you should see the revFileAssociation dialog ("LiveCode files
> > are not currently associated with this version. Would you like to make
> this
> > association?")
> > 3. Choose "Yes"
> >
> > Does the splash screen close after that?
> >
> > BTW if you want to close this stack manually, you can try that:
> >
> > - type in the msg box "close the mousestack" but do NOT press Enter
> > - place the cursor on the splash stack
> > - press enter
> >
> > I am wondering if an error occurs on startup, so LC stops execution, and
> > the line of code in the IDE startup scripts that closes this stack is
> never
> > reached.
> >
>
> I cleared the livecode7.rev prefs file (the only one I now have),
> restated Windows 8.1 (64bit). Launched LC9.0.0 and responded "Yes" to
> the revFileAssociation (which I had not previously been doing as I have
> been working in 8.1.9 recently). No luck. The Spash remains and I have
> the grey backdrop on. When I open Options in LC9 and click Reset to
> Default, the backdrop clears, but the splash remains. I have to close it
> by the message box trick. If I then quit LC9 and launch it again, the
> slash goes away appropriately, but despite having reset the Options to
> Default, the gray backdrop appears every time I launch LC9.
>
> If I launch another version of LC (say version 6.7.11) and click Yes to
> the file associate and then quit LC 6.7.11 and then launch LC9 and do
> not say Yes to the file association, then the splash and grey backdrop
> remain.
>
> If I launch LC9 and say Yes to the file associate and then close the
> splash manually and quit and launch again, the splash closes as it
> should. However, if I change the file associate I am back to a always on
> splash window in LC9.
>
> So, summary:
> Launching LC9 and answering No to the file associate leaves the splash
> screen visible even when exiting and restarting LC9 multiple time as
> long as you answer No to the file association.
> Launching LC9 and answering Yes to the file associate leaves the splash
> screen visible, but exiting and restarting LC9 resulting in the splash
> going away normally after LC9 is up and running.
> Again all under Windows 8.1 (64)
> I have no idea why I am now getting the grey backdrop.
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list