[ANN] Release 9.0.0

panagiotis merakos merakosp at gmail.com
Wed Apr 4 13:51:31 EDT 2018


@Peter
One more thing to try before filing a bug report:

1. Clear Prefs again
2. Open LC, you should see the revFileAssociation dialog ("LiveCode files
are not currently associated with this version. Would you like to make this
association?")
3. Choose "Yes"

Does the splash screen close after that?

BTW if you want to close this stack manually, you can try that:

- type in the msg box "close the mousestack" but do NOT press Enter
- place the cursor on the splash stack
- press enter

I am wondering if an error occurs on startup, so LC stops execution, and
the line of code in the IDE startup scripts that closes this stack is never
reached.

@Richard
Thanks for the update, I'll pass it to the team. I know we had at least
another 3 users in your area that suffered from very slow download speeds.
Network issues are hard to diagnose :)

Best,
Panos
--

On Wed, Apr 4, 2018 at 6:35 PM, Richard Gaskin via use-livecode <
use-livecode at lists.runrev.com> wrote:

> @Peter Bogdanoff bogdanoff:
> > Yesterday it took me 3-4 hours to download LC 9. I’m in California.
>
> Good to know I'm not the only one.  Thanks.
>
>
> @Panos:
> > Do you still experience slow download speed? I had no problem
> > yesterday from my home internet connection
>
> Thanks for asking. Yes, and it's been the darndest thing.  Not even my ISP
> could explain it.  It's been this way for more than a week, and persists
> this morning, even across multiple computers.
>
> I was able to find a workaround that demonstrates that it's not the
> livecode.com server per se:  I shelled into one of my VPSes in New Jersey
> and used wget to download the builds I needed - each took less than a
> minute there.  Then I copied them to my web folder, and on my local machine
> downloaded from that VPS - at normal speed.
>
> So to summarize what I've learned thus far:
>
> - It's not my computer: all computers here show this slow download
>
> - It's not your server: I can download from it to another computer
>   in a different geographic region with no delay.
>
> - It's not my local network setup: Peter has the same issue, and
>   downloading from my VPS is speedy.
>
> Given all this, my wild guess would be that this is something related to
> the CDN you're using (Cloudflare?), affecting only southern California, or
> maybe even more limited than that since Peter and I are less than about 20
> miles from one another.
>
> While Cloudflare's status page shows the Los Angeles area to be
> "Operational", a quick search at Google turned up a few discussions about
> issues in my area, the most recent I stumbled across being just 22 hours
> ago.
>
> The bigger mystery is that this has persisted as long as it has.  Most
> CDNs are super on top of things, and a multi-day issue is rare.
>
> At least I have a workaround for now, and if I learn anything more I'll
> pass it along.  In the meantime, if you hear of anything with your CDN it
> may be helpful to share.
>
> --
>  Richard Gaskin
>  Fourth World Systems
>  Software Design and Development for the Desktop, Mobile, and the Web
>  ____________________________________________________________________
>  Ambassador at FourthWorld.com                http://www.FourthWorld.com
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list