Codesigning fail LC 8.1.5, Xocde 8.3.3

Ben Rubinstein benr_mc at cogapp.com
Thu Jul 13 13:21:06 EDT 2017


Hi Panos,

(Apologies didn't have a chance to reply before) - fantastic, that sorted it. 
Thanks for the swift reply.

FFR, a slightly quicker fix than Mike's - perhaps easier to see because this 
was on a clean machine - I looked in keychain and it was obvious that of two 
identically named certs, one was younger than the other; so I deleted the 
older one and that fixed it - no need to re-downlaod.

BTW this has partly arisen because when I used xcode to sort out certificates, 
it seems to be creating ones that expire in a week? Has anyone else seen this?

thanks again,

Ben

On 13/07/2017 11:39, panagiotis merakos via use-livecode wrote:
> Hi Ben,
> 
> Yes, this probably happens because you have more than one certificates with
> the same name (and one of them is valid, the other is not). The standalone
> builder uses the name of the certificate to sign the binary, so it probably
> picks the invalid one and this causes problems.
> 
> Mike Kerner had the same problem, and here is how he resolved it:
> 
> "I'm getting the same error with XC 8.3.
> Interesting, though, I think I may have stumbled on the problem.
> Every time I launch XC and go into my account and the certs/profiles list,
> XC creates a new cert for development and a new one for distribution.  I
> just went into my keychain, removed all of the certs, re-downloaded them
> from the Apple Dev website, instead of from xcode, and reinstalled them.
> Build
> worked for both apps I tried."
> 
> A proper fix in the standalone builder will come soon, which will allow to
> choose the certificate based on the unique HEX id rather than the
> (non-unique) name.
> 
> http://quality.livecode.com/show_bug.cgi?id=20030
> 
> Hope this helps,
> Panos
> --
> 
> On Thu, Jul 13, 2017 at 11:24 AM, Ben Rubinstein via use-livecode <
> use-livecode at lists.runrev.com> wrote:
> 
>> Have proved that Xcode can make a default project, build and install on an
>> iPad running 10.3.2.  This is on a fresh MacBook running Sierra.
>>
>> Used a couple of weeks ago (with LC 8.1.4) for the same purpose (my main
>> machine is on El Capitan, hence can't have Xcode 8.3.3, hence can't build
>> for 10.3.2), successfully. Not used since.
>>
>> On attempting to update the build, got a load of invalid entitlements
>> stuff. Used xcode to reset certificates until it could build again.
>>
>> Now, under either LC 8.1.4 or 8.1.5, I get a message
>>          codesigning failed with /bin/sh: line 1: 869 Segmentation fault 11
>>          ...
>>
>> I'm cranking ahead of a demo tomorrow - any suggestions as to how I go
>> from here?
>>
>> Many thanks,
>>
>> Ben




More information about the Use-livecode mailing list