Google Static Maps Demo Available

Mark Wieder ahsoftware at sonic.net
Fri Jul 7 00:40:29 EDT 2017


On 07/06/2017 07:53 PM, William Prothero via use-livecode wrote:
> Mark:
> Hmmmm…. I checked it out and the problem is with LC 9.0 (dp7). The openstack script is in the first card in the main stack. It has the script to start using the various substacks that are needed. If I open it in LC9, this code somehow gets disabled and doesn’t show in the IDE editor. So, the substacks never get “used.” I tried opening a virgin version in LC 8.1.5(RC3) and it worked as expected. So, I guess this is a bug in the latest LC9 release.
> 
> I don’t know about the difficulty entering the APIKey. It works for me in LC8.1.5. lI’m on Mac, latest OS.
> 
> The link to get the latest (fixed) download is:
> http://earthlearningsolutions.org/google-static-maps-demo/ <http://earthlearningsolutions.org/google-static-maps-demo/>
> 
> You need to get this newest version, because I had tested it in LC9 and saved it, so the openstack script was deleted somehow.
> 
> I’ll be very interested to see if you have more troubles.

Thanks. That fixed all those problems (LC9dp6). No idea what was going 
on with the text field.

So I can load a map, and I can use the slider to zoom. I can type input 
parameters into the centering fields and the box corners and reload the 
map to see the changes, and I can see the mouse lat/lon values moving 
when I move the mouse. Is anything else supposed to happen? Clicking on 
the map does nothing. I realize the docs say 'The rest is pretty 
self-explanatory', so maybe I've done it all.

-- 
  Mark Wieder
  ahsoftware at gmail.com





More information about the Use-livecode mailing list