Could not encode class bundle

Ralph DiMola rdimola at evergreeninfo.net
Fri Dec 22 18:28:00 EST 2017


OK... back to the problem at hand

J,

On Win 10 I built/installed/ran an Android app using dp11. I have JDK
1.8.0_102 installed.
On the MacBook I successfully built but did not install using JDK 1.8.0_121.

Looks like JDK 1.8.0 is the magic sauce.

Hope this helps. Have a good holiday.

Ralph DiMola
IT Director
Evergreen Information Services
rdimola at evergreeninfo.net


-----Original Message-----
From: use-livecode [mailto:use-livecode-bounces at lists.runrev.com] On Behalf
Of Ali Lloyd via use-livecode
Sent: Friday, December 22, 2017 5:34 PM
To: How to use LiveCode
Cc: Ali Lloyd
Subject: Re: Could not encode class bundle

Yes, looking at previous instances of this error I think using JDK 1.8 is
the easiest fix. I'm not sure exactly why this changed from DP 10 to 11
though...

On Fri, Dec 22, 2017 at 10:04 PM J. Landman Gay via use-livecode <
use-livecode at lists.runrev.com> wrote:

> Okay, it's a very long error that I couldn't copy, but the first line is:
>
> Exception in thread "main" java.lang.UnsupportedClassVersionError:
> com/android/dx/command/Main : Unsupported major.minor version 51.0
>
> This is followed by a dozen lines of various java errors concerning 
> lang, security, net, and misc.
>
> I'm still using the Apple-supplied java installation 1.6.0. Do I need 
> a different one?
>
> On 12/22/17 2:26 PM, Ali Lloyd via use-livecode wrote:
> > Could you put
> >
> > "answer the result"
> >
> > before
> >
> > throw "could not encode class bundle"
> >
> > in the revSaveAsAndroidStandalone script? That should give us a clue 
> > as
> to
> > what the error is.
> >
> > On Fri, Dec 22, 2017 at 7:13 PM J. Landman Gay via use-livecode < 
> > use-livecode at lists.runrev.com> wrote:
> >
> >> On 12/22/17 12:56 PM, J. Landman Gay via use-livecode wrote:
> >>> I'm unable to build an Android app in LC 9dp11, I get "Unable to 
> >>> encode class bundle." I have installed all the Android build tools 
> >>> for every version (17 through 27.0.3), and also the latest SDK 
> >>> Tools (25.2.5) and SDK Platform-tools (27.0.1). I do not use Android
Studio.
> >>>
> >>> What else do I need? Preferences point to the correct SDK folder.
> >>>
> >>
> >> BTW, I was able to build with LC 9dp10.
> >>
> >> --
> >> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> >> HyperActive Software           |     http://www.hyperactivesw.com
> >>
> >> _______________________________________________
> >> use-livecode mailing list
> >> use-livecode at lists.runrev.com
> >> Please visit this url to subscribe, unsubscribe and manage your 
> >> subscription preferences:
> >> http://lists.runrev.com/mailman/listinfo/use-livecode
> >>
> > _______________________________________________
> > use-livecode mailing list
> > use-livecode at lists.runrev.com
> > Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
>
>
> --
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
_______________________________________________
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription
preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list