Android App Woes

J. Landman Gay jacque at hyperactivesw.com
Sun Aug 13 13:16:59 EDT 2017


There's more to it than just the script. I thought the problem was just in 
issuing the quit command but Dan can reproduce it using the Home key (and I 
bet the Recents key would do the same.)

It looks like the engine is unloading libraries in all these cases and not 
restoring them on resume. I didn't test it but front and backscripts might 
behave the same way.

--
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com



On August 13, 2017 12:00:23 PM Ralph DiMola via use-livecode 
<use-livecode at lists.runrev.com> wrote:

> The LC team does a good job at triaging the bug reports but a repeatable 3 
> line stack that crashes should be near if not in the front of the queue.
>
> Ralph DiMola
> IT Director
> Evergreen Information Services
> rdimola at evergreeninfo.net
>
>
> -----Original Message-----
> From: use-livecode [mailto:use-livecode-bounces at lists.runrev.com] On Behalf 
> Of J. Landman Gay via use-livecode
> Sent: Sunday, August 13, 2017 12:21 PM
> To: How to use LiveCode
> Cc: J. Landman Gay
> Subject: Re: Android App Woes
>
> Probably related :
>
> http://quality.livecode.com/show_bug.cgi?id=19420
>
> --
> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
> HyperActive Software           |     http://www.hyperactivesw.com
>
>
>
> On August 13, 2017 10:47:27 AM Dan Friedman via use-livecode 
> <use-livecode at lists.runrev.com> wrote:
>
>> I have built my android app with LC 8.1.5.   It runs fine on the device.
>> You then hit the home button to return to the OS.  Tap the app icon
>> again and you get “Unfortunatly, [appName] has stopped.”.  Tap the icon 
>> again and
>> it does a complete reboot of the app.   Apps made in LC 7 did not have this
>> issue, they stayed running in the background – like an app should.   Is
>> there a trick to getting an Android app from LC 8.1.5 to behave like it should?
>>
>> I can’t deliver an app to my client that (a) doesn’t stay alive in the
>> background, and (b) crashes every other launch.
>>
>> Anyone have any insight on this??
>>
>> -Dan
>>
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode






More information about the Use-livecode mailing list