Searching revBrowser content

J. Landman Gay jacque at
Wed Jan 27 00:33:08 EST 2016

The docs say I should be able to select text in a browser control by 
setting the "selected" property. Repeatedly doing that should iterate 
through all matches. I can't get it to select anything even once. Is 
anyone else able to execute this successfully:

  revBrowserSet sBrowserId, "selected", pString

The dictionary says it's a command but when I run it in the message box 
it says there's an error in the function. I assume that's because the 
engine treats it as a function internally. When I run it inside a 
handler in the script, no errors.

I tried this (the script local sBrowserID has the correct value):

on doFind pString
   revBrowserSet sBrowserId, "selected", pString --> nothing selected
   get the result --> always empty
   -- check to see what we have:
   put revBrowserGet(sBrowserId, "selected") into tSel --> always empty
end doFind

Does this work for anyone? I'm using the CEF browser because the plain 
old revBrowser won't load the file; it doesn't error but it shows no 
content, it's completely empty.

LC 7.1.1, Mac OS X Yosemite

Jacqueline Landman Gay         |     jacque at
HyperActive Software           |

More information about the Use-livecode mailing list