Can't open sqlite disk file in XP standalone

Dr. Hawkins dochawk at gmail.com
Sat Mar 7 14:39:54 EST 2015


I'm in odd waters at the moment, on XP (which is left over on a FreeBSD
laptop; I've never actually owned a windows machine, ever . . .)

Anyway, this application has compiled and run as a mac standalone for
years, and as a windows standalone compiled mac-side at some point in the
past.

I have a three line sequence

   answer "trying to open " & prefsFilNam
   put revOpenDatabase("sqlite", prefsFilNam , , , , )  into prefsDb
   answer "got: " & prefsDb

The directory in the pathname exists, and actually gets successfully
created a few lines previous if it doesn't exist (i've removed to check
this).

OK, it's a bug, bug 14838 <http://quality.runrev.com/show_bug.cgi?id=14838>
that I just filed.

The dlls are not landing where the should, as set out in the bug text below.

Is there a way to work around this until its patched?  Move files (I've
tried putting the dlls in the same directory as the executable, and putting
the folder of them there, to no avail.


The standalone compiles and places revpdfprinter.dll and
revsecurity.dll in the same folder as the executable.

Also created is an "externals" folder containing revdb.dll and folder
database_drivers, which in turn contains dbpostgresql.dll and
sqlite.dll (the two types selected in standalone settings).

Nonetheless, revOpenDatabase() causes an error (rather than returning
an errorcode).

The code works without problem in the IDE on both mac and windows, and
has worked in mac executables for years.







-- 
Dr. Richard E. Hawkins, Esq.
(702) 508-8462



More information about the Use-livecode mailing list