iOS Playing Sounds Problems

Magicgate Software - Skip Kimpel skip at magicgate.com
Mon Jun 29 14:15:36 EDT 2015


Actually, my issue was with "beep."  On second look, it does not appear to
be the same issue.  Just for reference, here was the bug reported for that:
http://quality.runrev.com/show_bug.cgi?id=15355

SKIP KIMPEL

On Mon, Jun 29, 2015 at 2:10 PM, Magicgate Software - Skip Kimpel <
skip at magicgate.com> wrote:

> I personally have had problems getting sounds to work on an iPhone.  From
> everything I can tell it has something to do with the iOS version I am
> using.  What device and what version is the device you are testing on?
>
> SKIP KIMPEL
>
> On Mon, Jun 29, 2015 at 1:51 PM, Randy Hengst <iowahengst at mac.com> wrote:
>
>> Hi All,
>>
>> I’ve been messing with a sound problem for several hours this morning…
>> can’t for the life of me see what I’m doing wrong.
>>
>> I have an app in which I’m using this format for loading the sounds:
>>       put specialFolderPath("engine") &"/"& "Blue.wav" into gBlueSound
>>       mobileSetSoundChannelVolume "Ch5","0"
>>       mobilePlaySoundOnChannel gBlueSound, "Ch5",”now"
>>
>>
>> I’m using newly recorded sounds and sounds from from previous projects.
>> The sounds from previous projects work just fine with this pattern… when
>> it’s time to play I call:
>>       mobileSetSoundChannelVolume "Ch5”,"100"
>>       mobilePlaySoundOnChannel gBlueSound, "Ch5",”now"
>>
>> I’ve also tried playing the sound with this format:        play
>> specialFolderPath("engine") &"/"& "Blue.wav”
>>
>> But, the 10 new sounds I’ve recoded play on the simulator, but not on a
>> device… while the “old” sounds I’ve used before work on both.
>>
>> As best I can tell the sounds are all the same …. 16 bits with a sample
>> rate of 44,100. I’m using .wav files but also tried .aif format.
>>
>> LC 6.7.5 • Mac OS 10.2 • Xcode 6.2
>>
>> Any thoughts about how I might have messed up the new sounds.
>>
>> Thanks for your help.
>>
>>
>> be well,
>> randy
>>
>> Randy Hengst
>> www.classroomFocusedSoftware.com
>>
>>
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
>
>
>



More information about the Use-livecode mailing list