Insertion point problems

Bob Sneidar bobsneidar at iotecdigital.com
Tue Jun 23 11:18:06 EDT 2015


Instead check the focusedObject. If it is a field then you can paste. 

Bob S


> On Jun 22, 2015, at 14:19 , David Epstein <dfepstein at comcast.net> wrote:
> 
> 1.  With a word selected in field 1 of the topStack, a menu button in a palette issues a command “Paste”.  The handler for this command includes
> 
> set the defaultStack to the topStack
> get the selectedChunk
> — test whether the chunk is a suitable place to paste, and if so then
> paste
> 
> This works fine if there is actually a word selected in field 1.  But if there is only an insertion point it does not work; the selectedChunk is reported as empty.  (On mouseDown on the palette menu, a selected word stays selected; but a blinking insertion point disappears).
> 
> 2.  Results above both in LC 5.5 and LC 7.01.  But I notice another problem in 7.01 (unlike in 5.5):  the insertion point does not blink.  I see it blink just after typing a character, and it blinks once when the stack is activated, but when nothing is happening there is no indication of where the insertion point is.
> 
> Do others see this, or have solutions?
> 
> David Epstein
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the Use-livecode mailing list