Do new Livecode 8 widgets work on mobile?

David Bovill david at viral.academy
Sat Jun 20 10:07:29 EDT 2015


Thanks ALI - that helps - made a start on a patch :)

On 20 June 2015 at 09:47, Ali Lloyd <ali at runrev.com> wrote:

> Hi David,
>
> If you do
>  put true into gRevDevelopment
> in the message box you'll find break points are honoured and you can also
> use the contextual menu to find the function you're looking for.
>
> Ali
>
> On Saturday, 20 June 2015, David Bovill <david at viral.academy> wrote:
>
> > Isn't it crazy that given how easy it is to edit and change / fix
> LiveCode
> > IDE stacks we are still waiting for the mothership to fix simple errors
> > like this instead of patching them and submitting fixes ourselves?
> >
> > The code is:
> >
> > on mouseUp
> > >    answer "What version of XCode do you have installed?" with "4.2 or
> > > earlier" and "4.3 or later"
> > >    if it contains 4.3 then
> > >       answer file "Select your XCode app bundle" with filter "APPL"
> > >       if it is not empty then
> > >          put "/Contents/Developer" after it
> > >       end if
> > >    else
> > >       answer folder "Please choose the developer root for your iOS 5.0
> > and
> > > above SDK"
> > >    end if
> > >    if it is not empty then
> > >       if *revIDEDeployIOSIsValidSDK*(it) then
> > >
> > > *         setIOSSdk it*
> > >>
> > >       else
> > >          answer error "The chosen folder is not a valid iOS SDK."
> > >       end if
> > >    end if
> > > end mouseUp
> > >
> >
> > I can't find exactly where the "*setIOSSdk" *handler is. I guess the
> error
> > is in the revIDEDeployIOSIsValidSDK() function - which I can;t find
> either.
> > Any tips with regard to how to debug IDE errors - given the debugger
> seems
> > to get a bit flaky when debugging the IDE - checkpoints are not
> recognised?
> >
> > On 19 June 2015 at 23:41, Dave Kilroy <dave at applicationinsight.com
> > <javascript:;>> wrote:
> >
> > > Sorry I must have given you bad advice - I just installed Xcode 6.3.1
> and
> > > it
> > > didn't work with LC 8 dp1 or dp2 - maybe when LC 8 came out in early
> > April
> > > I
> > > was using Xcode 6.3.0 - I was also probably running an earlier version
> of
> > > iOS...
> > >
> > > I think unless we can recreate the same conditions in our development
> AND
> > > test machines to those we had in early April that we are stuffed until
> > they
> > > bring out dp3
> > >
> > >
> > >
> > > -----
> > > "The difference between genius and stupidity is; genius has its
> limits."
> > -
> > > Albert Einstein
> > > --
> > > View this message in context:
> > >
> >
> http://runtime-revolution.278305.n4.nabble.com/Do-new-Livecode-8-widgets-work-on-mobile-tp4693205p4693217.html
> > > Sent from the Revolution - User mailing list archive at Nabble.com.
> > >
> > > _______________________________________________
> > > use-livecode mailing list
> > > use-livecode at lists.runrev.com <javascript:;>
> > > Please visit this url to subscribe, unsubscribe and manage your
> > > subscription preferences:
> > > http://lists.runrev.com/mailman/listinfo/use-livecode
> > >
> > _______________________________________________
> > use-livecode mailing list
> > use-livecode at lists.runrev.com <javascript:;>
> > Please visit this url to subscribe, unsubscribe and manage your
> > subscription preferences:
> > http://lists.runrev.com/mailman/listinfo/use-livecode
> >
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list