LC Android: Invalid Keystore Format error when saving a standalone for deployment

Matthias Rebbe | M-R-D matthias_livecode_150811 at m-r-d.de
Thu Jun 11 04:37:14 EDT 2015


Ralph,

thanks for recommending Keystore Explorer.

I can open my keystore file w/o problem.


Maybe my problems have to do with the fact that i have setup my mac in April this year from scratch?

Is it possible that there are some certificates or keys missing? 

Regards,

Matthias



> Am 11.06.2015 um 02:00 schrieb Ralph DiMola <rdimola at evergreeninfo.net>:
> 
> See if you can open it with "Keystore Explorer". It's a great GUI way to deal with the keystore. It runs in the java machine so it is platform independent.
> 
> Ralph DiMola
> IT Director
> Evergreen Information Services
> rdimola at evergreeninfo.net
> 
> 
> -----Original Message-----
> From: use-livecode [mailto:use-livecode-bounces at lists.runrev.com] On Behalf Of Matthias Rebbe | M-R-D
> Sent: Wednesday, June 10, 2015 7:28 PM
> To: How to use LiveCode
> Subject: LC Android: Invalid Keystore Format error when saving a standalone for deployment
> 
> Hi,
> 
> maybe i am missing something.
> 
> I have to update an app i uploaded to the google store mid 2014.
> 
> For  creating the standalone i am using of course the same keystore file i used for the version from 2014.
> 
> After i enter alias and the 2 passwords i get the following error message
> 
> “There was an error while saving the 
> standalone application
> signing failed - keystore load: Inavlid
> keystore format"
> 
> 
> What could cause this error?
> 
> I wanted to try a fresh version of the android SDK to see if this solves my problem, so  I downloaded the most recent version of Android SDK and installed SDKs for 2.2 and 2.3.
> But with the new version i get an error “There was an error while saving the standalone application. could not generate package manifest”. The most version of the Android SDK Build-tools are installed in SDK Manager.
> 
> 
> So if someone has an idea what is going wrong here.
> 
> 
> I am working on Mac OS X 10.10.3, LC 6.7.5, Android SKD 24.3 and JDK 1.6. 
> 
> I know 1.6 is outdated, but i need it for a iSCSI driver which only runs with 1.6.
> 
> Regards,
> Matthias
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list