Funkiness with snapshot

William Prothero prothero at earthednet.org
Thu May 29 19:51:31 EDT 2014


Folks:
I tried my app (working in LC 6.6) in 6.7 dp4. There is still funkiness in the snapshot command. I can’t reproduce it in a test app (I submitted a test app to the bug reporting system and LC folks verified the bug). There are two snapshots in succession and the first one works, but the second one only works if I put a breakpoint just before the second snapshot. What I’m doing is drawing a graph by creating line objects, fields, etc, then taking a snapshot of the graph and deleting the objects, leaving a snapshot of the graph. I get a blank snapshot. What appears to be happening is that the creating and drawing of the graphic objects that create the plot are not getting finished drawing before the snapshot is taken.

 This might also be a problem with the “wait for 0 seconds with messages” command. I put this where the breakpoint was put, and the snapshot still takes a blank image. So, as I write this, I’m suspecting a problem with “wait for 0 seconds with messages”. I tried wait for 1 seconds with messages” and it didn’t help.

I am not going to be able to upgrade my app to beyond 6.6 unless this is fixed. I hope the team takes a look at this. I think this would be a common problem.

Regards,
Bill Prothero

William A. Prothero, Ph.D.
University of California, Santa Barbara Dept. of Earth Sciences (Emeritus)
Santa Barbara, CA. 93105
http://es.earthednet.org/






More information about the Use-livecode mailing list