silent fail of revDataFromQuery() in standalone; works in IDE

Matthias Rebbe | M-R-D matthias_livecode_150811 at
Fri May 23 18:50:59 EDT 2014

Is it possible that you have a SaveStackRequest handler in your card or stack script?
And if so, could you check if maybe the line "pass savestackrequest" in that handler is missing?

I ran into this some time ago. I had a savestackrequest handler without the line "pass savestackrequest".
This missing line caused exact the same error you are describing. 



Am 24.05.2014 um 00:33 schrieb Dr. Hawkins <dochawk at>:

> This section of code has worked for quite some time.  Now, it's failing in
> standalones, but works just fine in the ide.
> I already have an in-memory SQLite database open at cacheDb.  The ck
> command just puts to the message box and after a log window.
> dcmd is shown as
> dcmd: CREATE TABLE  clientNameRemoved_001_dinfo  (kywd VARCHAR(20), dTyp
> CHAR(1), usr VARCHAR(20),   tstmp TEXT, val TEXT, dfl TEXT, dvl INTEGER,
> ddf INTEGER, dta TEXT, ch BOOLEAN, UNIQUE(kywd) ) ;
> For the code
>   ck "dcmd: " & dcmd
>   put revDataFromQuery(,,cacheDb,dcmd) into theRes
>   answer "theRes:" & theRes
> I get to the answer in the IDE, with a table created successfully.
> In a standalone, though, the answer command is not reached, and the handler
> exits silently.
> -- 
> Dr. Richard E. Hawkins, Esq.
> (702) 508-8462
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the Use-livecode mailing list