Fighting with audio player again

J. Landman Gay jacque at
Mon Oct 7 18:11:36 EDT 2013

Thanks for listening, Scott. I was ahead of you, I tried that yesterday 
but no go. The times where I did get playback, it was using a pre-used 
player. But I just tried a new player object again to be sure and...nothing.

I've been thinking about AWS distributed servers. They must be 
delivering data differently. It's all I can think of. Besides ghosts, I 

On 10/7/13 2:41 PM, Scott Rossi wrote:
> Sounds like some otherworldly behavior (we are getting close to
> Halloween).  Ghosts in your machine?
> Radical suggestion: To reset the player, maybe try completely deleting the
> player object, and creating a new one, as opposed to just setting the
> filename to empty -- the ultimate reset.  It sounds like you have *some*
> success with playback, so if something is getting "stuck", maybe a new
> player object will get beyond that.
> Regards,
> Scott Rossi
> Creative Director
> Tactile Media, UX/UI Design
> On 10/7/13 12:28 PM, "J. Landman Gay" <jacque at> wrote:
>> On 10/7/13 2:04 PM, Richard Gaskin wrote:
>>> J. Landman Gay wrote:
>>>> On 10/7/13 1:06 PM, Richard Gaskin wrote:
>>>>> LiveCode uses a very old and long-since-deprecated set of APIs for
>>>>> working with native media playback on Windows.  Until LC is updated to
>>>>> use newer APIs, whether the native Win player app can play a file is
>>>>> not
>>>>> a reliable test of whether LC can also play it.
>>>> I probably need to be more specific. LiveCode will play the remote mp3
>>>> okay if it uses a "normal" URL -- that is, a standard URL like:
>>>> These URLs are on Amazon Web Services (AWS) and so they are coming from
>>>> a distributed server system. I can't imagine why that would make any
>>>> difference but it seems to. The URL is of the form:
>>>> It's the same file. The only difference is the distributed server URL.
>>>> IE plays it, LiveCode won't.
>>> Downloading and streaming behavior very differently.  AFAIK LC can only
>>> play streams via QT.
>> Is "fast start" a streaming format?
>> Here's a new twist. I made a new stack yesterday with nothing but a
>> player and a button that sets the filename of the player to empty and
>> then to the URL. It works, and playback is immediate. I repeat that lots
>> of times successfully. Then suddenly it doesn't work, I get "can not
>> open player". After that it doesn't work any more. I come back the next
>> day, set the filename, it works.
>> So I use the message box to set the filename of the player in my real
>> mainstack to the same URL. It never works.
>> One more thing. Yesterday I did the message box thing in the real
>> mainstack and of course it failed, so I just left it alone and did
>> something else for a while. A full hour later I'm startled out of my
>> socks when it suddenly starts to play. A whole hour later, all by
>> itself. I can pause, restart, set the currentTime, it all works. So I
>> set the filename to empty via message box, then set it to the same URL
>> again. Nothing. I wait an hour. Nothing.
>> I'm losing hair.
>> --
>> Jacqueline Landman Gay         |     jacque at
>> HyperActive Software           |
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

Jacqueline Landman Gay         |     jacque at
HyperActive Software           |

More information about the Use-livecode mailing list