livecode on xubuntu 13.10

Martin Baxter mblivecode at harbourhosting.co.uk
Sun Dec 22 15:29:54 EST 2013


On 22/12/13 18:07, Mark Wieder wrote:
> Martin-
> 
> Sunday, December 22, 2013, 9:42:24 AM, you wrote:
> 
>> This weekend I've been trying to get Livecode 6.1  running on
>> xubuntu 13.10 64bit
> 
>> After installng 32 bit compatibility stuff and manually copying
>> 32bit dependency libraries from another ubuntu machine as I
>> couldn't immediately figure out how else to install them, I did
>> succeed in getting it to run.
> 
> Stuff like this is why I left Xubuntu for the happier climes of
> linux mint. Did you install the ia32 or ia32arch libraries? What
> dependency libraries did you have to copy? If you're not building the
> engine from source I don't know what else would be required, although
> it's been a while since I did this and may not be remembering
> properly.
> 

It was a struggle trying to figure out what to install. I first tried
ia32-lib via apt, but got the reply that it had been "replaced" by 3
other libraries whose names I can't immediately recall (it was late last
night), which anyway I duly installed.

The multiarch package didn't seem to be avialable either, I couldn't
find it listed in Synaptic anyway. Some *possibly* related things but...
Anyway that still left the livecode installer not running. I ran ldd to
see what it needed and where it might like them to be, found those libs
on my other machine and copied them over, until eventually the installer
ran.

Those were:

libX11.so.6.3.0
libXau.so.6.0.0
libxcb.so.6.0.0
libXdmcp.so.6.0.0
libXext.so.6.4.0

(with symlinks in each case for e.g xxxxx.so, xxxxx.so.6)

The ide then also ran, but as I say, with mouse pointer issues.

As for the standalone, I wonder if the 4.5 engine is not usable on a
more recent Linux, or if Xubuntu is just dodgy. I'm leaning to the
latter explanation currently.

I'm wondering whether to wipe it and start again with some other distro,
indeed I'd like to, or if it's just that I'm unfamiliar with this distro.

I wanted to install CentOS originally, but the LiveDVD of 6.4 was flaky
enough to eat (assuming enough cream on it ;) so I balked. I only
installed Xubuntu because a) installation actually worked and b) I can't
be doing with them new-fangled Ubuntu versions. I may try with a
slightly earlier version of CentOS. I've tried Live CDs and DVDs of
current offerings from Mint and OpenSuze, but all exhibit issues. The
machine I'm installing on is not new, in fact it was home made and back
in the day it ran Red Hat. It may of course have BadBIOS disease, maybe
that's the problem.

Martin




More information about the Use-livecode mailing list