lock/unlock screen

Mark Wieder mwieder at ahsoftware.net
Thu Sep 20 11:00:54 EDT 2012


Thursday, September 20, 2012, 1:29:32 AM, you wrote:

> That 'multiple lockscreen' thing does seem illogical and/or daft, and it
> might not be a bad thing if it were changed so that 'locked' meant 
> 'locked once' and was not ambiguous.

It's actually quite useful as is. It means I can write smaller
routines that fiddle with the screen, locking before and unlocking
afterwards. I can then string these routines together in a larger
construct, locking before and unlocking after, without needing to
worry about the screen suddenly popping to life (and slowing things
down) in the middle. Remembering to unlock after you've locked isn't
any more cumbersome than remembering to close parentheses or quotes.

-Mark Wieder
 mwieder at ahsoftware.net

More information about the use-livecode mailing list