revCopyFile questions

Peter Haworth pete at
Fri Jun 1 19:10:58 EDT 2012

Thanks Jacque.  I treid the formats you recommended and I'm still getting
"execution error" back from revCopyFile with nothing else in the result.
 The disk image is mounted.

I checked for the presence of the disk image using the message box as you
suggested using the message box and got true..

I also checked the application file availability using the message box and
got true.  Interestingly, you have to use "there is a folder" not "there is
a file" to check for the existence of the .app file/folder, even though you
use revcopyfile to copy it.  The path to the appfile was copied and pasted
directly from the error message I display so I'm certain I'm using the
correct path.  I even used the message box to issue a revcopyfile of the
app file to my desktop and that worked

I'm beginning to wonder if revCopyFile is capable of handling disk images.

This is all part of my post build processing to get ready for a release, so
I could just copy the app file manually but would be nice to get it working
by script.

lcSQL Software <>

On Fri, Jun 1, 2012 at 10:47 AM, J. Landman Gay <jacque at>wrote:

> On 6/1/12 11:30 AM, Peter Haworth wrote:
>> I'm trying to use revcopyfile to copy an application from a folder on my
>> disk drive to a mounted disk image (OS X).  Keep getting "Execution error"
>> from revCopyFile which really isn't very helpful.
>> When copying an application file, should the file name be "myApp" or
>> ""?  Or should I be using revCopyFolder?
> Use revCopyFile and include the ".app" at the end. Provide the full path,
> the one you'd get back after an "answer file" dialog.
>> What is the correct path to the mounted disk image?  I'm using
>> "/Volumes/myImage.sparseimage"**, also tried specialFolderpath("Home")&
>> "/Volumes/myImage.sparseimage" ( which I'm pretty sure isn't right).
> It should start with "/Volumes/". To see if you have the path right try
> this in the message box: there is a folder "/Volumes/myImage". I assume the
> disk image is mounted already, right? If so, I don't think the
> ".sparseimage" should be in the path because a mounted volume doesn't use
> that.
>> Lack of a clear error message from revCopyFile is making it hard to figure
>> out exactly what I'm doing wrong.
> Is the vague error the only thing you get in the result? As far as I know,
> checking the result is the only way to get any info. If any of the paths
> are wrong you should get an error about not being able to open the file, or
> no such folder (or something similar; can't recall offhand exactly what it
> says.)
> --
> Jacqueline Landman Gay         |     jacque at
> HyperActive Software           |
> ______________________________**_________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:

More information about the Use-livecode mailing list