lc shell and command line

Mike Bonner bonnmike at gmail.com
Mon Nov 14 17:06:34 EST 2011


oh that sucks. I tried quite a few other methods none of which worked very
well if at all.

Hmm, would calling login directly work?  Probably not, as on many systems
root login is not allowed. If it were allowed, then the same basic idea
works.  open process login then do the magic stuff, then exit out.

Also looked at suid ideas but couldn't make a suid script do root level
stuff no matter what I tried.

Makes me wish for a less fragmented linux. Oh well, open elevated is
working for me on ubuntu. Wish I had things that needed to be done that way!

On Mon, Nov 14, 2011 at 2:53 PM, Mark Wieder <mwieder at ahsoftware.net> wrote:

> Mike-
>
> Monday, November 14, 2011, 12:16:39 PM, you wrote:
>
> > open elevated process seems to work ok. The following handler, opens bash
> > as an elevated process, then writes to it and reads from it.  Should be
> > possible to run a pre-made shell script too.
>
> That's a nice script. Unfortunately opening elevated processes doesn't
> always work, as for instance on Fedora Core, where for some reason
> that got deprecated by around version 9.
>
> --
> -Mark Wieder
>  mwieder at ahsoftware.net
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list