Weird script behaviour (was libUrlDownloadToFile & urlProgress)

Gerry gerry.orkin at gmail.com
Wed Mar 23 21:46:03 EDT 2011


Jacq

Figured it out. Later in the card script I set up a scroll control, and include this line in that setup script:

iphoneControlSet sScrollerId, "declerationRate", fast

The compiler doesn't like that line. If I comment it out or put "fast" in quotes, everything works fine.

My scroll control setup is taken from a demo stack I found on the runrev forums, and it works in that demo stack, and in mine. In my naivety and cluelessness (hell, I've been at this for 2-3 weeks in total, after many many years away from any form of programming or scripting) I assumed that the compile error I was getting against that line had something to do with the fact that I was running on a Mac - after all, on the iPhone the scroll control works fine with it included and I've seen other examples of scroll control scripts that include that line, apparently without problems.

So, sorry for bothering the list with my human error :) And thanks again for your interest.

Gerry

-- photo site: http://gerryorkin.com

On Thursday, 24 March 2011 at 10:13 AM, J. Landman Gay wrote: 
> On 3/23/11 4:57 PM, Gerry wrote:
> > Jacq, the button is on the card, and isn't in a group.
> 
> It's bizarre, I've never heard of anything like this. If you like, send 
> me a copy of the stack and I'll take a look. You've got me curious.
> 
> -- 
> Jacqueline Landman Gay | jacque at hyperactivesw.com
> HyperActive Software | http://www.hyperactivesw.com
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> 





More information about the Use-livecode mailing list