URLencode bug?

Mike Bonner bonnmike at gmail.com
Fri Mar 18 00:44:55 EDT 2011


I ran into this earlier and tried to ask about it, but wasn't very clear.
 When you urlEncode the field it turns it into one huge unbroken line, and
certain lengths of unbroken lines cause fields some problems it seems. The
line length you get from the urlEncode is within the accepted limits
according to docs, but something seems broken in fields. To see this in
action, try this stack.. Click add data several times till the line length
gets to 14700 and poof.  Only the overflow shows.  I didn't bother to find
the exact breakover point, but there it is. Also, behavior varies with line
wrap on and off. With line wrap off, things poof when you get to to 8400
line length, but the overflow never shows.  So my feeling is its a field
problem, not an encode problem.

go URL "http://guidezone.info/FieldBug.livecode"



On Thu, Mar 17, 2011 at 9:50 PM, Chipp Walters <chipp at chipp.com> wrote:

> I am trying to URLencode some data and for some reason it won't encode.
>
> Can anyone else get this to encode? It's a simple text field with no funny
> chars.
>
> Here's a test: (put in msg box and hit return)
> go URL "http://www.widgetgadget.com/stuff/URLencodeBug.livecode"
>
> For some reason it CAN URLencode the first 3111 chars, but barfs on any
> past
> there. Is there a char limit to what URLencode works on?
>
> TIA,
> C
>
> --
> Chipp Walters
> CEO, Shafer Walters Group, Inc.
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list