Tooltips not closing with change of app focus on OSX - bug?

Keith Clarke keith.clarke at clarkeandclarke.co.uk
Sat Mar 12 13:39:31 EST 2011


...thanks for the confirmation, Richard. Interesting, merely moving the mouse doesn't close it for me - I have to click in the tooltip.
Still, the sparkling new QA bug report 9444 refers.
Best,
Keith.. 

On 12 Mar 2011, at 16:29, Richard Gaskin wrote:

> Keith Clarke wrote:
> > Does anyone else notice that open tooltips fail to close when the
> > focus moves from LiveCode (IDE or a stand alone) to another app
> > on OSX?
> > Is this a new bug - I can't see anything obviously related on the
> > QA forum?
> 
> Confirmed:  If I hover the mouse over the LC IDE's Tools palette and wait for the tooltip to appear, then Cmd+Tab to another app, the tooltip does indeed stay visible.  However, as soon as I move the mouse the tooltip hides as expected; it may be that because the mouse must remain stationary to see this behavior that it hasn't been discussed much.
> 
> If this isn't in the RQCC it might be good to add it, since I suspect it would be an easy fix to add suspend to the actions that dismiss a tooltip and would give the app a more polish feeling.
> 
> --
> Richard Gaskin
> Fourth World
> LiveCode training and consulting: http://www.fourthworld.com
> Webzine for LiveCode developers: http://www.LiveCodeJournal.com
> LiveCode Journal blog: http://LiveCodejournal.com/blog.irv
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list