Follow the rev tools palette by a window

zryip theSlug zryip.theslug at gmail.com
Sat Nov 13 05:45:36 EST 2010


On Sat, Nov 13, 2010 at 8:39 AM, Richmond <richmondmathewson at gmail.com> wrote:
> On 11/13/2010 01:16 AM, zryip theSlug wrote:
>>
>> On Mon, Mar 1, 2010 at 10:02 PM, zryip theSlug<zryip.theslug at gmail.com>
>>  wrote:
>>>
>>> Dear list members,
>>>
>>> To follow the rev tools palette by a window (a palette), I use the
>>> send message in time form below :
>>>
>>> command scanForRevToolsLoc
>>>   set the topLeft of this stack to the bottomLeft of stack "Revtools"
>>>   send "scanForRevToolsLoc" to me in 100 milliseconds
>>> end scanForRevToolsLoc
>>>
>>> This handler works as expect excepted for one thing: it seems that
>>> dragging the tools palette by it's title bar, give no time to the RR
>>> engine. So during the drag, nothing is intercepted by the
>>> scanForRevToolsLoc handler. It performs only when the user release the
>>> mouse on the palette.
>>>
>>> Is it possible to have something more in "real time"?
>>>
>>> TIA
>>
>> I reply myself to this old message I sent. I agree that is a bad
>> habit, but that is the fault of Richmond!

Richmond,

> Molluscan humour?

Have you ever seen a slug smile, hum?

> Now; down to business!
>
> Do you mean that when you drag the revTools palette you want another
> stack to follow it (e.g. 'glued to' one side)?
>
> I have done this previously, having at one time had a supplementary
> palettised stack with additional controls that followed the revTools
> palette.

I experimented that with a small color picker palette.

> HOWEVER, there was a bit of lag-time and after a while I began to feel
> seasick.
>
> In that sort of situation you could probably get away with a few lines of
> script in the revTools stack script such as:
>
> on mouseDrag
>  set the left of stack "myRubbish" to the right of stack "revTools"
> end mouseDrag

With no change in the revTools code, just by inserting a front script
it seems possible to remove this lag-time.

Here is the result of the code I sent:

http://www.aslugontheroad.co.cc/index.php?option=com_phocadownload&view=category&id=2:tools&Itemid=63

The Color Picker plugin will ask for an update.

Could you confirm you have no lag-time after the update?

Thanks!


Best regards,
-- 
-Zryip TheSlug- wish you the best! 8)
http://www.aslugontheroad.co.cc



More information about the Use-livecode mailing list