Standalone problem

Mark Schonewille m.schonewille at
Fri Nov 12 07:55:10 EST 2010


it looks like something removed some files, inlcuding the "empty' engines that are the basis of standalones built by Revolution. Just re-install a fresh copy of Rev and all should be solved.

Here's some additional info:

Best regards,

Mark Schonewille

Economy-x-Talk Consulting and Software Engineering
KvK: 50277553

Economy-x-Talk on Facebook now and get a free Color Converter license (read the conditions)

On 12 nov 2010, at 09:20, Joe Lewis Wilkins wrote:

> OK, this is the problem. I've been working full time on an app for the better part of a month or more. When I first started, it consisted of a main stack and a sub-stack. One had 68 cards; the other 280. Not really complicated stuff. Full card images with fields and buttons on top of the images and complete TitleBar Menus. A good UI. When nearly complete, I built a standalone. No problem with either the Mac or Windows versions. I then decided, for some very good reasons of my own, to split the Main stack into a main and another sub-stack. Once I completed that, not as easy as you might think, I tried to build another standalone. The first time through I got a dialog saying that the standalone was successfully built; however three warnings appeared below that statement.
> 1. Icon does not exist:/Applications/Revolution Studio/4.0.0-gm-1/Runtime/Windows/x86-32/Support/Sample Icons/genericapp.ico
> 2. Could not build for Windows because required files are missing.
> 3. Could not build for MacOSX because required files are missing.
> I diddled around with the Standalone settings a bit, found a couple of things that might have been the problem and built it once again. This time the same thing happened, but there were only two warning:
> 1. Could not build for Windows because required files are missing.
> 2. Could not build for MacOSX because required files are missing.
> I thought, Gee Whiz, I must have fixed the Icon problem. So I diddled some more and built it once again. To my chagrin I got the original three warnings again. I have now tried to build the application in excess of a dozen times, making no other changes by diddling with anything; the result being that I receive alternate warnings. 3 then 2, then 3, then 2, etc. etc. Talk about frustration!!!!!!!!!! Unless someone has an easy resolution to this problem, Rev will no longer be in my toolbox, even though I've used it for lots of things that don't require a standalone or Window's versions. I certainly won't be moving up to LC.
> If interested, I'm working on a MacPro with OSX 10.6.5 and Rev 4.0.0-gm-1.
> Joe Wilkins

More information about the Use-livecode mailing list