iOS apps not getting past review due to crashing

Randy Hengst iowahengst at mac.com
Mon Dec 13 19:29:04 EST 2010


Hi Brian,

I had the same comment from Apple. The email indicated the splash launched.... then nothing.

The app I submitted works on an iPhone 3GS running 4.0 and several iPods running 4.1. I've not tried it on an iPhone 4 nor with 4.2.1. I don't have access to the iPhone 4, but will try using 4.2.1.

The message I got from Apple said:
We were unable to review your app at this time because it failed to launch on iPhone 4 running iOS 4.2.1. We have included the following details below to help explain the issue and hope you'll consider revising and resubmitting your application.

We encountered the issue when selecting the application on the Home screen - the app displayed a launch image then quit unexpectedly. There are several possible reasons for this behavior. One reason might be that iOS 4 uses a watchdog timer for applications, which means if an application takes too long to complete its initial startup, the operating system terminates the application. 

I shared this information with rev support, on Dec 10th. 

take care,
randy hengst
-----
On Dec 13, 2010, at 5:05 PM, Brian Meriaho wrote:

> Hi,
> 
> Has anyone else had a problem getting past the review step with iTunes
> Connect when submitting an app for Apple's App Store? I've built an
> app that runs on several iPhones, checked the certificates, checked
> the launch times, but still get rejected with a simple "it crashed".
> Not sure what is left to check.
> 
> Regards,
> 
> -Brian
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list