Weird RunRev IDE Problem

Eric Chatonet eric.chatonet at
Thu Jan 17 09:43:49 EST 2008

Hi Dave,

All this sounds normal to me :-)
'it' is not defined here.
To define 'it', you must put a value into or request a command, like  
get, read from file, convert, ask or answer that feed 'it'  

Le 17 janv. 08 à 15:39, Dave a écrit :

> Hi All,
> I always set the "Variable checking by default" preference on so  
> that Local's have to be defined. This has been working fine for at  
> least 6 months (when I installed this version on RunRev). Now  
> today, I get an error on the following code:
> function TestFunc
> local myValue
> put it into myValue
> return empty
> end testFunc
> The problem is that it's complaining that the "it" is not defined!  
> As I say, I've been using it and referencing "it" and "result" ok  
> (without the quotes), now for no apparent reason it gives the error:
> "expression: unquoted literal"
> I tried removing the "into myValue" so it just reads "put it" but I  
> still get the same error.
> Also, once I've hit this error, it fails to open the preference  
> panel when selected from the Menubar, the only way I can get it the  
> preferences up after this is to quit RunRev and re-launch.
> Any ideas on how to overcome this or what is going wrong? I'm dead  
> in the water now as code that used to compile ok, suddenly doesn't!!!
> All the Best
> Dave

Best regards from Paris,
Eric Chatonet.
Plugins and tutorials for Revolution:
Email: eric.chatonet at

More information about the use-livecode mailing list