Help with table fields and cell editing

André.Bisseret Andre.Bisseret at
Thu Oct 5 05:04:51 EDT 2006

Hello !
I am interested in using table fields but I tried twice spending  
hours to find how to use them and twice I gave up !
I think I wanted too much, given the poor current state of this type  
of fields.

But I never observe what you describe
So I just tried to replicate  what you are going through.
On a Mac Pro Intel OS X 10.4.8 and Runrev  2.7.4 (build 291).

Le 4 oct. 06 à 18:29, Walton Sumner a écrit :

> Help!
> I have a Rev 2.7.4 (build 291) PC interface for database editing  
> that is in
> great shape except for one feature, directly editing a list of  
> points. It
> seems to me that this should be a natural table field & cell  
> editing task,
> but I can not see how to make it work.
> I have a group that contains a table field. The table field is not  
> locked,
> the "Table object" setting is checked, the "cREVTable(celle" box is  
> checked
> (cell editing), and the maximum editable column is set to 2. The  
> tab stop is
> less than half the width of the field, after subtracting the width  
> of the
> vertical scroll bar. Problems persist with or without a horizontal  
> scroll
> bar.
I created a new stack with this same settings
> The field has the following odd behaviors when it is populated with  
> data:
> 1. A mouseup event within a cell temporarily erases the data in the  
> cell
> rather than selecting the data in the cell,
not here for me : the data are not erased , they are selected
> even if I drag over the cell
> contents and manage to select them before releasing the mouse. If the
> mouseup occurs outside of the cell, the contents of the cell remain
> selected.
Yes I get the same, but is it a real problem ?

> Clicking in a cell also causes the erasing mouseup event.
I don't see what you mean exactly here ? what's "the erasing mouseup  
event" ?
> These
> are incorrect behaviors, IMO - the end user should be able to click  
> or drag
> in the cell and insert or change one or a few digits.
I am able to click, drag, insert or change one or a few digits

> After clicking in a cell in the first column, clicking a different  
> cell in
> the first column causes the first cell's contents to reappear (correct
> behavior)
well, here it did not disappear
> 2. Clicking any cell in the second column erases the entire field's
> contents. The field does not recover when the cell is deselected.
this does not happen here; the entire field's contents remain unaffected
> 3. Clicking any cell in the second column selects the cell, but  
> scrolls the
> field horizontally so that the cell's left edge abuts the left edge  
> of the
> field, displaying the out-of-bounds third column and totally  
> obscuring the
> first column.
does not happen here

> This is also incorrect behavior, IMO. The selected cell will
> accept new text, let's say "ABC", after turning off the keydown  
> handler that
> screened for digits.
> 4. Tabbing from cell to cell has the same effect as clicking on a  
> cell in
> the second column.
here tabbing from cell to cell selects each cell successively, normally
> 5. After reloading the table contents from the database, clicking  
> on any
> cell in the second column erases everything but restores the "ABC"  
> that I
> entered in #3.

I only populated the table manually ; so I can't say anything here

> So, I'm guessing that the table field is not updating its global  
> descriptors
> correctly, as reported in the archives from 2003 and 2004, but I  
> can't see
> that anyone else has these problems currently. In fact, there are  
> messages
> that talk about letting Rev handle tabs and arrows and the like, as  
> if my
> current problems are not reproducible at all. Also, I thought until  
> now that
> Rev's field issues had been resolved.
> So is there some special combination of settings that makes the  
> table work?
I don't understand the difference between our respective results ? I  
had the same settings you described.

One strange behaviour here :  it is working when the table is set to  
"lock text" or "unlock text" as well !

Waiting for much better table fields, I am using  adjacent fields  
that work as columns ;  the script of the last one coordinates the  
behavior of the all including a handler on mouseWithin set the  
vScroll of fld "suchfld" to the vScroll of me.

Best regards from Grenoble

> Meanwhile, I'll be scripting a redundant interface to achieve point  
> editing
> with tab keys and no mouseclicks.
> I can post to bugzilla if this the problem is not unique to me.
> Thanks in advance.
> Walton Sumner
> _______________________________________________
> use-revolution mailing list
> use-revolution at
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:

More information about the use-livecode mailing list